Prox / RFID
Ladder Logic
[interfacing] †
Tube Joints
Key Code From Photo
SolveSpace (3d CAD)
SketchFlat (2d CAD)
Resume / Consulting
Contact Me

LDmicro Forum - LDmicro.GitHub news v4.0.9

(you are viewing a thread; or go back to list of threads)

LDmicro.GitHub news v4.0.9 (by Ihor Nehrutsa)

== Release 4.0.9

* Fixed: AUTO_PAGING version 4.1 for PIC's.

* Fixed: HEX is not created if a compilation error occurs.

* HOW TO: Two three phase sine wave based on the hardware PWM

* HOW TO: RF (315MHz, 418MHz, 433MHz, 915MHz) modules with PIC's and AVR's

* New: Added elements
UART SEND: Is ready ? Output is 1 when transmit buffer is empty and ready to loading new data.
UART RECV: Is avail ? Output is 1 when there are unread data in the receive buffer.

Mon Nov 14 2016, 06:58:57, download attachment build409.zip
(no subject) (by Alex)
Hello Ihor:

i opened a 4.0.7v ladder in 4.0.9v and i got this (see image), is it because no compatible at all?, at the end it opens the any way (ok)
Mon Nov 14 2016, 07:59:20, download attachment 1.jpg
(no subject) (by Alex)
i have to admit it, the topic about time in ldmicro was always concerning me because i wanted it to be the more exactly it could, so i thought that making a clock from here:


was the best way to test it, so i tested it the more it could last with ldmicro 4.X.Xv, it worked for 3 weeks without any problem because there was a balckout in my house :D , but, before the blackout a little number one (literally) showed up (iamge attach) but it was working ok, after the blackout i decided to test it in ldmicro 2.3v, it worked very well during one day, because fortunatly i catched it the moment it reset it self , milliseconds was like the seconds (i donīt know if i explained it very well), and the hours and minutes reseted, then the milliseconds that its speed was like the seconds then turn to milliseconds again, everything was reseted, so even there are some bugs in ldmicro 4.x.xv because it is under fixing, it works pretty well.
Mon Nov 14 2016, 21:57:03, download attachment 15107312_10157771915315344_7226171224304047159_n.jpg
(no subject) (by Ihor Nehrutsa)
You need one or more space char ' ' after the last digit in FORMATTED_STRING
------{":\2 "}--
Char ' ' will rewrite the garbage, if it occurs.
Tue Nov 15 2016, 00:21:33
(no subject) (by Alex)
i would like to share some bugs (if not, correct me please):

BUG 1:


the zone where I/O pins, internal, counters, etc are shown are invisible, they are there but invisible when open a ladder file. (i opened a 4.0.7v ladder with 4.0.9 v)

BUG 2:


this bug is described in:


it shows a message "RAM out of memory".

Important, in this video, this ladder file was in "ANSI C code" format, so when i pressed and I/O (invisible) it shows up a list of pins but is says "falta pata" i think i would be in English "missing pin" the problem i thats when it is in "ANSI C code" it should show up a message like in 2.3v (image attach), that tells me that i canīt add pins because it is in "ANSI C code".

BUG 3:


Important, in this video, again i opened a 4.0.7v ladder with 4.0.9v and message describe in "BUG 1" didnīt showed up.

In this video i did te opositte, i opened a 4.0.7v ladder with pic format (16f877A) and then i chosse "ANSI C code", then i compile, finally it shows up a message describe in "BUG 2".

When this message shows up, both timers "T1" and "T2" of the video turns invicible, then i click on "R1" and it turn invicible too, then i canīt click anything, i think it shows up an invicible char of pins, but remember it is now in "ANSI C code"...

i had to shoot it with the task-manager because i couldnīt click on the "x (cancel)" of the invicible char.
Tue Nov 15 2016, 01:44:27, download attachment 2.jpg
(no subject) (by Ihor Nehrutsa)
I don't see BUG 1 "Invisible I/O list" on my Windows XP.

== Release 4.0.10

* Fixed: EEPROM reading 'Empty variable name' message.

* Fixed: Messagae "RAM: Out of memory...") for non hardware MCU.

I made some changes to the I / O list.
Please test.
Tue Nov 15 2016, 06:45:51, download attachment ldmicro_4010_pre_release.zip
(no subject) (by Alex)
i tested it, first of all, thanks for your reply, great progess error message shows up preventing that we canīt choose pin because it is en ansi c. I tested turning from ansi c to pic, and from pic to ansi c.


Here something, in ldmicro 2.3v, when i select a pin (with a microcontroller set), for example pin 33, and then i select ansi c code, that Pin on MCU (pin33) disappears because now it is in ansi c, but, when i select back again the same microncontroller, same pin 33 shows up again, in 4.0.10 pre release,if i do it the same way, my pin 33 is not restored i have to add it again, this could be a little problem when selecting from MCU to ansic c for big ladders, we would need to add again all I/O pins, i think pins should be restored when selecting from ansi c to a the specific pin.


there was a error described here:


that hex is created any way, it was fix in this release (4.0.9) but it creates *.asm if error anyway.


and last, sincerely not a big deal, but when the error message "Must assign pins for all I/O" (image attach), 2 clicks are needed for closing the message and not one :D
Tue Nov 15 2016, 07:52:10, download attachment 3.jpg
(no subject) (by Alex)
thanks a lot for your work, great progress :)
Tue Nov 15 2016, 07:52:40
(no subject) (by Alex)
sorry in 1)

last sentence should be like this:

i think pins should be restored when selecting back from ansi c to the specific pic.
Tue Nov 15 2016, 08:21:41
(no subject) (by Boris)
Compile problem with 4.0.6 and 4.0.7 OK, with 4.0.9 error
Thu Nov 17 2016, 15:06:11, download attachment 4.0.9.GIF
(no subject) (by bfwolf)
Hello Ihor:

pre-release 4.0.10 looks very promising! :-)

But i found some 'funny' behavior:

If you load the 'hello-m328.ld' and choose 'compile' (F5) or 'compile HEX' from the menu, the file is compiled to a HEX-file named 'hello-m328.hex' as expected.
If you then choose 'compile ANSIC' from the menu, the compilation behaves als before with 'compile HEX' but a file 'hello-m328.c' is generated which also contains HEX data.
If you again choose 'compile ANSIC' a 2nd time from the menu, a file 'hello-m328.c' is generated which contains C-source...

Another question: why do you delete the existing 'hello-m328.hex' if one chooses 'compile ANSIC' after ???

Happy testing ;-)
Thu Nov 17 2016, 15:14:24, download attachment hello-m328.ld
(no subject) (by Alex)

1)compiled in the first time:

microcontroller selected----> compile MENU ------>Compile ANSCI C

"generates c file that containts hex"

2)compiled in the second time:

microcontroller selected----> compile MENU ------>Compile ANSCI C

"generates only c file"
Thu Nov 17 2016, 19:39:41
(no subject) (by Alex)
all of that described before happens after compiling hex in menu
Thu Nov 17 2016, 22:20:03
master control relays (by pacifico)
version 4.0.9 no master control relays effect on rungs
Thu Nov 24 2016, 19:52:19, download attachment test led out dubix.txt
master control relays (by pacifico)
version 4.0.7 no effect master control relays in this version, ok in version 2.3
Thu Nov 24 2016, 20:00:42, download attachment lavatrice 24 novembre p16f877 dubix 3p.ld
(no subject) (by MGP)
You are right, it does not work anymore since version 2.3.

I use it for my 7seg readout.

I made a testprogram for better testing.
Fri Nov 25 2016, 01:59:49, download attachment MasterRelay-Test.ld
Problemas con LDMicro (by Gregorio Gonzalez)
Saludos. Amigos tengo un problema. He bajado versiones de ladder soportado con arduino mega. Hago el programa, lo compilo, lo vinculo al proteus. Todo bien hasta ese momento. Cuando le doy ejecutar el proteus carga el programa pero el diseņo no ejecuta las instrucciones dadas en el programa. PAra ver si era el arduino, lo hice con un pic y tampoco funciona.
Es importante mencionar que en versiones anteriores del ldmicro, como por ejemplo, el 2.3 , el proteus lo carga y el diseņo ejecuta las instrucciones dadas. Sería de gran ayuda tu opinión al respecto. De antemano muchas gracias por la pagina web.
Fri Jan 11 2019, 18:47:51
Post a reply to this comment:
Your Name:
Your Email:
(no HTML tags; use plain text, and hit Enter for a line break)
Attached file (if you want, 5 MB max):